My esc key stopped working since installing Slido

  • 6 October 2021
  • 1 reply

This post is for myself and my boss. We recently installed Slido on our mac laptops using Chrome and Google Drive.  Ever since we did that, our Esc key no longer works so when we’re in a Google slide presentation (Google Chrome/Mac), and we need to escape it, we can’t.  The only workaround is to rightclick and choose reload.  What’s up with the Esc key no longer working?


Additionally, my boss reported that she can no longer use the laser pointer when sharing her Google slides in Zoom.  This has worked all along until Slido was installed.  


Boss tried to uninstall Slido but it keeps re-appearing.





1 reply

Userlevel 4

Hi @Jo-AnnCK,

Since we haven’t really experienced this issue before, I have a couple of follow up questions to make sure we get this fixed for you!

  • Do you also have our Chrome Extension installed or is it just the Google Slides integration?
  • Have you tried restarting your browser? (On Mac, hitting command+Q should do the trick)


Unfortunately, we don’t support laser pointer, so that’s why it’s no longer working for you when using our integration.


Please let me know if the restart helped. I’ve also passed this issue on to our product team to investigate further and will let you know as soon as I know more from them!