How do I add Slido to my Microsoft Teams meeting?

  • 4 February 2021
  • 5 replies

I am really struggling to see the benefit of bothering with Slido in teams  - I just don’t get the + sign to add it to my meeting. I did once, a long time ago.This integration just doesn’t seem to work :-(


5 replies


Hi @ruthn1963,

As discussed in our Integrate Slido with Microsoft Teams article, I’m really sorry to hear about this issue. 

If you'd like to troubleshoot with us why you can't see the + sign in MS Teams anymore, feel free to reach out to my colleague Martin at who'll be happy to take a further look.

Once again, thank you for your feedback and hope you'll enjoy Slido in the future.

Hi, any luck with the + sign? I have the same problem.. Thank you :-)

Hi. To enable Teams Slido at enterprise level. Does all that need to happen is the Teams Slido app gets released/unlocked?


Hi @Helen,

If you scheduled your meeting and you still can’t see the + button, please make sure at least one participant is invited to this meeting. Once done, go to Edit the meeting and the + button should be available. If it doesn’t appear, however, one of the following might be the cause:

  1. In the invite, there is the whole Channel invited (Teams does not support in-meeting apps in Channels yet)
  2. Make sure you have enabled Turn on new meetings experience under Microsoft Teams Settings → General.

Hope this helps but please do let us know in case of any further questions, we’re here to help.




Hi @Thalaivar,

That’s correct, in some cases where there are certain internal restrictions in place, Slido needs to be whitelisted by your IT administrator. Once done, Slido should be available in the Microsoft app store together with other in-meeting apps.